The issue has been resolved, and Git app integrations operate normally. The incident was caused by a high rate of incoming tasks, which created a bottleneck in our queueing system and led to delays in task processing.
Our team has implemented the necessary fix and will continue to monitor the system closely to ensure continued stability. We sincerely apologize for the inconvenience this may have caused and appreciate your patience throughout the resolution process.
If you continue to experience any issues, please don’t hesitate to contact our support team.
Posted Jul 04, 2025 - 20:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 04, 2025 - 19:49 UTC
Identified
The issue has been identified, and we are actively working on applying the necessary fix to restore functionality without delays.
Posted Jul 04, 2025 - 14:46 UTC
Investigating
We are investigating intermittent delays with GitHub, Bitbucket, and Gitlab Integrations. You may experience a delay in your workflows.
Our team is actively working to mitigate the delays while simultaneously investigating the root cause of the issue.
We will provide an update as soon as we have more information to share. Thank you all for your patience, and apologize for any inconvenience caused.